FAQs

Ask a Question

PME 9. Billing Module / Rate editor does not work with Finish Localization

Problem overview:
The Web Rate Editor does not work correctly if Finish settings are selected.  The first time allows you to edit the file but if you include decimal values (that uses “,”) the second time you open the file it shows empty rows.
 
I deployed test with Localization
English (Finland) and Suomi(Suomi)-customer needs this-
And I could reproduce the same behaviour. 
For more details, please refer to the attached file or to BFO case ​
51894408

Resolution
1. Go to \Schneider Electric\Power Monitoring Expert\applications\RateEditor\_lib\ and move the "rateeditor.js" to another location  (don't just rename) in case you have to revert.
2. Download the "rateeditor.js" attached below and move it to Schneider Electric\Power Monitoring Expert\applications\RateEditor\_lib\
3. Restart the services or the server if possible and try again.  (Not mandatory but recommended)

I tried the steps above on my test system where I reproduced the issue and works well.

INTERNAL ADDITIONAL INFORMATION FROM L4

They have discovered a couple of other problems if Finnish settings are used:
1. You can't choose a custom date range in Diagrams.
2. In the new 9.0 Alarms app, when clicking an Alarm or Incident link for "Open Representative Waveform" the call will fail to open the waveform viewer with a message stating that no waveforms can be found. NOTE:  This does not affect the ability to view waveforms via the Analysis Timeline or "Waveform Tab" of Alarms or Incidents

 
Was this helpful?
What can we do to improve the information ?