Technical FAQs

Ask a Question

ETSNZ - Why is my functional level of my M221 Somachine application not compatible with the firmware?

If you get a warning whilst creating a program in Somachine for your M221 controller:
"The Functional levels of the application and of the firmware are not compatible"

You can fix this by upgrading the firmware or by lowering the functional level of the application.
Version 1.3.2.1 was released end of march 2015 and is present on your computer if you have installed  v1.3 SP1 for SoMachineBasic software.
The file directory is:  C:\Program Files (x86)\Schneider Electric\SoMachine Basic\Firmwares & PostConfiguration\M221\V1.3.2.1

To Sumarise:
Upgrade your firmware first to v1.3.2.1
Set the application level to the level requierd.


 
Was this helpful?
What can we do to improve the information ?